Date Created: Tue 27-Nov-2007

Related Document Categories:

Get my WebSphere Application Server course here >> http://www.themiddlewareshop.com/products/


Servlet class <classname> for servlet <servletname> could not be loaded because the requested class was not found in the classpath .

Error code from WebLogic Server


Error 500--Internal Server Error
javax.servlet.ServletException: [HTTP:101249][ServletContext(id=12041646,name=test,context-path=/test)]: Servlet class SendMailServlet for servlet SendMail could not be loaded because the requested class was not found in the classpath E:\bea\weblogic81\samples\domains\examples\examplesServer\.wlnotdelete\extract\examplesServer_test_test\test.war;e:\bea\weblogic81\samples\domains\examples\.\examplesServer\.wlnotdelete\extract\examplesServer_test_test\jarfiles\_wl_cls_gen.jar;e:\bea\weblogic81\samples\domains\examples\.\examplesServer\.wlnotdelete\extract\examplesServer_test_test.

java.lang.UnsupportedClassVersionError: SendMailServlet (
Unsupported major.minor version 49.0).
at weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubImpl.java:905)

at weblogic.servlet.internal.ServletStubImpl.getServlet(ServletStubImpl.java:598)

at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:406)

at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:348)

at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:7047)

at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)

at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:121)

at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletContext.java:3902)

at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:2773)

at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:224)

at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:183)




JDK and Eclipse Configuration


When you install Eclipse 3.2 it will automatically use JDK 1.5 with compiler compliance level 5.0 (not 1.4!). If you plan to use compliance level 1.4 you should go to Windows - Preferences -Java - Compiler and set up the proper Compiler compliance level.


Get my WebSphere Application Server course here >> http://www.themiddlewareshop.com/products/


Steve Robinson - IBM Champion 2013

About Me

Steve Robinson has been working in IT for over 20 years and has provided solutions for many large-enterprise corporate companies across the world. Steve specialises in Java and Middleware.

In January 2013, I was awarded the prestigous 'IBM Champion' accolade.


  • Linked In
  • Twitter
  • About Me
  • My Blog
  • Contact Me

Read my books?

IBM WebSphere Application Server 8.0 Administration Guide

IBM WebSphere Application Server 8.0 Administration Guide

WebSphere Application Server 7.0 Administration Guide

WebSphere Application Server 7.0 Administration Guide

WebSphere Categories

Other Categories